Matrix Booking Knowledge Base

User account keeps being disabled

Problem

  1. My user account keeps being deactivated.

  2. An employee’s account keeps being disabled. What can I do?

Cause

Note: this is only applicable to customers using our Microsoft Entra ID integration.

There are 2 reasons for this:

  • Your Entra ID sync has user accounts that are marked for deactivation.

  • Your Entra ID sync isn’t linked to your whole directory and you have groups.

Solutions

Your Entra ID sync has user accounts that are marked for deactivation

If you’ve switched on Entra ID sync, the user account is likely marked for deactivation in your directory. When Matrix Booking syncs with your directory everyday at around 4am, it will only sync only the active user accounts.

Contact your IT team to let them know they need to amend the field in your directory called accountEnabled. If this field is set to FALSE, NULL, or left empty, this marks the account as deactivated. It needs to changed to TRUE. The account will no longer be deactivated when we syncs with your directory.

Your Entra ID sync isn’t linked to your whole directory and you have groups

If the all the users have accountEnabled set to TRUE but the issue persists, the other reason user accounts are deactivated is that your Entra ID sync is set up to sync a specific group. Contact your IT team to check whether your Entra ID sync is set up for your whole directory.

Learn more about Matrix Booking’s SSO and Entra ID integrations