Matrix Booking Knowledge Base

Why does my booking get cancelled after I get a booking confirmation notification?

Problem

  1. Why does my booking get cancelled after I get a booking confirmation notification?

  2. Why do I get an accepted booking only for it to be declined later?

Cause

If you’re using our Microsoft 365 integration, you may receive a booking confirmation followed by a cancellation email. This happens when the two systems sync and the booking is rejected by one of them, because either:

  • The resource is unavailable.

  • Your organisation’s business rules (such as cost codes) conflict between Matrix Booking and Microsoft 365.

Solution

To resolve this issue, you need to give and ask the following from your IT team:

  1. Give them a screenshot of the error message you’ve come across.

  2. Ask them to make sure that the calendars are synced correctly.

  3. Ask them to make sure your business rules match between the two systems.

If you’re still getting an error message, raise a support ticket and provide screenshots of the error message, the Matrix Booking resource calendar, and the Microsoft 365 resource calendar.

Notes:

  • We recommend using our Microsoft 365 add-in as this will provide the most up-to-date information on your resource availability in Matrix Booking.

  • If you don’t have access to the Microsoft 365 resource’s calendar, ask you Matrix Booking administrator or your IT team to check it for you.

  • Any resources that are linked need to go through the future booking syncing process. This step is extremely important – if missed, your resource calendars will be out of sync and cause confusion to your users.

Find out more about our Microsoft 365 integration caveats and limitations